[ADOBE] Erro Flex Builder cannot locate the required debugger version of Flash Player

Publicado: 16/09/2013 em Cotidiano, Erros, Google, Internet, Programação, Softwares, Truques & Dicas, Tutoriais / Info
Tags:, ,

erro_AdobeFlex

Cliente é cliente, então não adianta chorar..

E dessa vez a dor de cabeça tem sido em cima da ferramenta Flex Builder da Adobe, cuja qual sinceramente acho que SOEMNET essa empresa usa..

E na necessidade de uma “pequena”alteração, e eis que ganho o seguinte erro quando tento realizar o modo de debug da ferramenta:

This is the message I receive when it breaks:

” Flex Builder cannot locate the required debugger version of Flash Player. You might need to install the debugger version of Flash Player 9 or reinstall Flex Builder. 

Do you want to try to debug with the current version? 
flex error rob mccardle
e  ai vem a dúvida…
o que fazer????
Desinstalar e reinstalar?
Talvez eu só preciso de um bom reiniciar?
Fico pensando o porque disso, já que antes de mais nada atualizei o Adobe Flash Player para última versão.

Bem, a caixa de diálogo tem um link/URL para o site da Adobe.

Sendo assim, eu clico achando que isso resolveria o caso, apontando a versão a ser usada e bastando um simples download..Mas, NÃO…..

Ao ir para o link Adobe Flash Player Support Center , a coisa fica MUITO confusa já que não sei QUAL versão usar , baixar e por ai vai. (

DEBUGGER (AKA DEBUG PLAYERS OR CONTENT DEBUGGERS) AND STANDALONE (AKA PROJECTORS) PLAYERS FOR FLEX AND FLASH DEVELOPERS

 

Mas considerando que a mensagem dizia que eu precisava da versão 9 ( sei lá porque se estamos na 11) , então selecionei a opção

Get older versions ( que redireciona para o novo link)

No grupo de Older Archives, encontro a versão 9..issoé 4 versões dela…

  • Flash Player 9.0.280 and higher (21.8 MB)
  • Flash Player 9.0.280 and higher (debugger versions) (23.7 MB)
  • Flash Player 9 (253 MB)
  • Flash Player 9 (debugger versions) (223 MB)

E então considerei a versão com maior tamanho ( já que assim “deve “ser completa) , e  (223 MB) depois extraio os arquivos e novo tormento…

Afinal, “Trocentas pastas”..e eu lá sei QUAL usar???

flex01

Bem, optei pela “crença” que a versão mais nova…( 9r277 ) , seria a mais adequada…

Tsc..Tsc…

Mesmo problema persiste…

Eis que pensei, bem vamos REMOVER TUDO….. e com isso , localizo a Ferramenta de Desinstalação do Flash Player,  que por sua vez explica na sua página como prosseguir com a desinstalação.

Depois de desinstalar, remover os arquivos como orienta a Adobe e reiniciarr a máquina.

Fui verificar a instalação para confirmar não haver mais nada. E como esperado ( até que enfim) , nada instalado .

Retomei os arquivos do Flash Player 9 (debugger versions) (223 MB), e dessa vez optei pela versão “mais velha” ( 9r15) .

Executei o Flex Builder,  colocquei em modo de debug e o infeliz reclamou DE NOVO..mas dessa vez foi “gentil”e orientou-me , informando que eu precisava instalar a versão (9r115), e dentro dessa pasta devem ser instalados os arquivos:

  • flashplayer9r115_win_debug.exe
  • flashplayer9r115_winax_debug.exe

Por fim, fechei e abri o Flex novamente e dessa vez , tudo funfando…

Debug em estado lindo de execução… e só lembrando que o debug do Flex Builder utiliza as teclas e atalhos diferentes do Visual Studio, então sugiro a leitura AQUI e AQUI:

 

Anúncios

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s